MediaSignage support forum

community support => Report bugs and errors => Topic started by: itehno on May 02, 2011, 12:43:13 PM

Title: Player stuck after reboot
Post by: itehno on May 02, 2011, 12:43:13 PM
I was testing one player configuration, default setup, with daily restart at the midnight. It was working normally for several days, and I left it working over a weekend.
This morning, our ADSL connection was down (problem at providers side), and player was  stuck at transparent player window without any text. I restarted it, signage controller started normally, transparent player window without any text shows, and then it stuck again.
This was strange, because I thought that player works ?no meter what happens?. When network goes down, it should reproduce ?last cached state?.
Then I took second player (it was previously used, normally registered and had some cached data), and exactly the same thing happened.
Can somebody explain this? If this is a feature, and not a bug, I think that it must be changed. 
Title: Re: Player stuck after reboot
Post by: admin on May 03, 2011, 06:34:33 AM
Hello,
The SignagePlayer Desktop player does work offline, sure.
Now you may ran to a specific bug so we need to reproduce it.

1. Are you using the Scheduler in your campaign?
2. What if you just rest the player (not use the Daily power savings), it works ok?
3. Are you using 2.X or 3.X mediaCLOUD?

Regards,

Sean - MediaSignage.com

Title: Re: Player stuck after reboot
Post by: itehno on May 03, 2011, 09:54:59 AM
Hello,

1. No, both are sequenced. Btw, those two players are totally independent, businesses and campaigns are different, even OS is different (one is Windows and one is Ubuntu).
2. I am not using any daily power saving, and reboot conditions for both players are default (station reboot every day at midnight). I wrote that I reset the player (start/turn off/restart), and it stuck at the same place.
3. Both players are 2.x latest version.

I belive that it is something related both to specific network situation, and time. Both players are physically plugged into working lan, but without internet access (they could not reach the server), both were not updated for several days (one was turned off, and the other rebooted at least once, but it was not able to reach the server because there was no internet).
Our ADSL connection is still down (no internet access), and I left both players on purpose "stuck as they are" to see what will happen when WAN comes back (it should be tomorrow). I will write what will happen.

If you have any suggestion, please tell me.

I think that you should be able to reproduce this, shut down the player for few days, and before you boot it again, make sure that it is physically connected to working lan, but without access to the server.

Regards

Title: Re: Player stuck after reboot
Post by: itehno on May 04, 2011, 03:00:05 AM
Short update. When WAN access (ADSL) was restored, nothing happened, both players were still stuck. After I manually restarted them, everything went well, they booted normally and started presentation. I will try to reproduce the same error later.

Regards
Title: Re: Player stuck after reboot
Post by: itehno on May 04, 2011, 11:03:08 AM
It is easy to reproduce the bug:
1) Boot the player normally, and leave it working for few minutes.
2) Block access to the server, but don't disconnect ethernet cable from the player! (in my case, I did it by disconnecting router from ADSL line).
3) Physically reset the player.
4) After reboot, player will stuck.
5) After restoring access to the server, nothing happens, player must be manually restarted.

Only if you disconnect ethernet cable, and reset the player, it will boot normally, and work "off line".

Regards

 
Title: Re: Player stuck after reboot
Post by: admin on May 04, 2011, 03:02:26 PM
I followed the steps and all seems fine...
Which OS are you using?
Title: Re: Player stuck after reboot
Post by: itehno on May 05, 2011, 03:35:33 AM
One is Ubuntu 10.10, the other is WinXP Pro SP3, both players are 2.2.1088, AIR 2.6.0.19140.

I think that problem is in the way of IP addressing.

We have typical SOHO network, integrated ADSL modem/router/DHCP server/4 port switch (Thomson ST780), and additional four switches.
Both players were in DHCP mode. When I disconnect ADSL modem from the line, and restart players, they both stuck.
Now, when I set static IP addresses to both players, in the same situation (disconnected ADSL line) they both booted and started normaly. Also, if I leave them in DHCP mode, and shut down DHCP server, they both booted and started normaly.

I hope that this will help you to reproduce and correct this bug.

Regards


Title: Re: Player stuck after reboot
Post by: theadtv on May 05, 2011, 05:57:11 AM
itehno, i am having similar problems. Mine works fine when i start the player manually but it seems like at night when the network is updating or something it is interferring with the media box causing it get stuck on a administrator log in screen. I have 2 other media players that are working just fine on a Non-Network environment.

The media player is not rebooting on its own which i thought would happen if it goes offline or turned off, i have to manually turn off/on and it works fine till the next morning. Sean helped me and noticed i had the monitor setting to turn on/off on the "power saving" tab. He had me turn it off cause there might be a bug with it. I will find out this morning if it works and probably test it for another couple days.

check your setting under the power saving tab and put it to none..see what happens.

theadtv
Title: Re: Player stuck after reboot
Post by: admin on May 05, 2011, 07:16:57 AM
Yes keep us posted theadtv
Title: Re: Player stuck after reboot
Post by: itehno on May 05, 2011, 07:33:49 AM
itehno, i am having similar problems. Mine works fine when i start the player manually but it seems like at night when the network is updating or something it is interferring with the media box causing it get stuck on a administrator log in screen. I have 2 other media players that are working just fine on a Non-Network environment.

The media player is not rebooting on its own which i thought would happen if it goes offline or turned off, i have to manually turn off/on and it works fine till the next morning. Sean helped me and noticed i had the monitor setting to turn on/off on the "power saving" tab. He had me turn it off cause there might be a bug with it. I will find out this morning if it works and probably test it for another couple days.

check your setting under the power saving tab and put it to none..see what happens.

theadtv
Hello,

Thank you for your effort, I wish it was something simple like that, but it is not. If you read the whole thread carefully, you would notice that those are two different players, with different OS, and identical behavior.
I hope that Sean will find time to simulate the situation that I described, and to reproduce the bug.

Regards
Title: Re: Player stuck after reboot
Post by: itehno on May 12, 2011, 01:36:30 AM
Hello,

Did you try to reproduce the bug, it really takes only few minutes? If you are not certain what causes this behavior, I will have to use static IP-s (which is not big problem), but I would really appreciate answer and opinion from your side.

Regards

Title: Re: Player stuck after reboot
Post by: admin on May 12, 2011, 06:33:41 AM
yes I was not able to reproduce,  can you try another OS?
Title: Re: Player stuck after reboot
Post by: itehno on May 13, 2011, 12:11:26 PM
I tried both Windows and Ubuntu, same thing. I think it is not OS related. Any other suggestion?

Regards
Title: Re: Player stuck after reboot
Post by: theadtv on May 24, 2011, 03:25:51 PM
I think it is a network environment issue, i brought home the player that was acting up and played it for 5 days with no problems.

I had an issue with my stand alone player with no network environment, it got stuck on the "signage will return momentarily" and it never rebooted. The studio was saying it was offline but it was on when i got there just stuck in that loop
Title: Re: Player stuck after reboot
Post by: admin on May 24, 2011, 08:17:54 PM
So its a local firewall that is preventing communication with us?
Title: Re: Player stuck after reboot
Post by: GRAFIXMEDIA on July 20, 2011, 04:48:09 AM
I? having similar problem where when internet connection is down and Ethernet cable is plugged in then signage player starts transparent mode and it stays like that.

If Ethernet cable is unplugged from computer and computer restarted then it starts but only the old campaign which is cached on the computer.

When Ethernet cable is plugged and no internet connection or service is down then signage player will not start no mater what you do.

It looks like signage player on start-up tries to check if any changes have been made to the station and since there is no internet it gets stuck and just waits.  Strange thing is even after internet service is restored it fails to pick that up & have to manually restart
Title: Re: Player stuck after reboot
Post by: admin on July 20, 2011, 06:28:28 AM
What version of the player are you running?
Title: Re: Player stuck after reboot
Post by: GRAFIXMEDIA on July 21, 2011, 11:28:49 AM
Im Using Player Ver 3.0.1087 but I was having same problem with Ver 2.2.1088
Title: Re: Player stuck after reboot
Post by: itehno on July 30, 2011, 07:17:26 AM
Please try to assign static IP address to the player. If this helps, than this is identical situation as mine. Clearly, it is a BUG, but Admin says that he can not reproduce it ....
Title: Re: Player stuck after reboot
Post by: admin on July 30, 2011, 07:28:25 AM
If an IP solves the issue it must be a OS / firewall restriction which explains why almost no one else has this issue and we can't reproduce the issue.  Our system is based on Adobe AIR which is independent of any IP interface binding so it must be none standard TCP/IP Firewall related issue.


If you are having issues connecting to our server you must have issues with a local firewall.
We support both LIVE Sockets as well as HTTP Polling.
Under the SignageStudio  > Stations you may get 3 color indicators:

Yellow: connected via Polling
Green: connected via live socket
Red: not connected at all
To learn more about this and how it is setup, please watch this video tutorial:
http://mediasignage.com/html/signage_video.html?videoNumber=ServerConnection
Title: Re: Player stuck after reboot
Post by: GRAFIXMEDIA on August 04, 2011, 12:28:13 PM
It is the easiest BUG to reproduce.
When all is working fine just close the signage player.
Now unplug the ADSL Filter from the wall socket
Do NOT unplug the RJ45 (Network) Cable from modem/Router or Computer
Now try to run Signage Player again
It will not run.
Title: Re: Player stuck after reboot
Post by: admin on August 04, 2011, 04:27:34 PM
I have tried this and works perfect on 2.x and 3.x
As soon as I plugged back in I got the reboot screen and presentation resumed.

Eric.
Title: Re: Player stuck after reboot
Post by: itehno on August 05, 2011, 11:56:55 AM
Hello Eric,

Can you please tell me what is the last state if you do the following sequence:
1) presentation runs normally
2) unplug the ADSL line
3) restart the computer
If I am correct, controller will start the player, but it will stuck at the first transparent screen. Please confirm this.

Now, try to restore ADSL line (plug it back), and tell me what happens (in my case nothing).

Regards
Title: Re: Player stuck after reboot
Post by: admin on August 05, 2011, 07:17:55 PM
Have you tried different resources in your presentation, maybe a particular resource is causing an issue?
Title: Re: Player stuck after reboot
Post by: itehno on August 07, 2011, 04:39:09 AM
Strangely, my last post disappeared ?! Anyway, problem is OS independent, and campaign (resource) independent. Two completely different computers, running different campaigns, on different operating systems (Windows XP and Ubuntu), suffer from the same problem at the same time.

I would really appreciate if you can answer on my last question.

Regards   
Title: Re: Player stuck after reboot
Post by: admin on August 07, 2011, 07:18:31 AM
I went ahead and opened a ticket for this so we can further investigate as soon as release 3.1 and 3.2 are out.
Title: Re: Player stuck after reboot
Post by: itehno on August 08, 2011, 03:54:28 AM
OK, thank you.

Regards
Title: Re: Player stuck after reboot
Post by: alfpc on September 01, 2011, 09:30:02 AM
I just finished the instalation and loaded all the content  to my player via an USB memory the player with all content and internet connection works perfect.

I can Restart the machine via SignageStudio, restart just the player with any problem... all work perfect with internet.

I need to move this player to a place where there isn't internet yet. Then I did try disconnect the network cable  and restart the machine. When it restart the SignagePlayer stuck just in the gray transparent window and nothing happen until the network cable (with internet) is plugged again.

I have the same problem in any player that get restarted (electricity fail, scheduled restart anythin) and if there isn't internet it get stucked.

IS THERE ANY PROCEDURE TO GET THE SYSTEM WORKING OFFLINE????
ANY RECOMMENDATION????

SOME DETAILS:

APLICATION VERSION: 2.21088
AIR VERSION: 2.7.1.19610
OS: windows XP professional
Memory: 2GB
Procesor: Core 2 duo
windowsXP Firewall: off
INstalation Date: Thu, September 1, 2011
Signage Campaing: Scheduler

HELP PLEASE

Title: Re: Player stuck after reboot
Post by: GRAFIXMEDIA on September 05, 2011, 01:49:56 PM
Alfpc maybe this helps
Yes & No

Yes
In my case I noticed that BUG only effects if computer is connected to router or switch using Ethernet RJ45 cable. I?m not sure about WiFi or wireless.  Unplugging RJ45 cable from the player will force player to start & play chosen campaign. If you take these players to location where no internet connection then without RJ45 & WiFi disabled from wireless network connections on player should work.

No
You will not have comfort to update any changes to the player from your office chair.
You will have to plug in RJ45 Network cable or enable WiFi properties for player to get updated.