July 19, 2019, 12:13:02 PM
Welcome, Guest. Please login or register
News: Stay up to date with everything that's happening at http://plus.digitalsignage.com

MediaSignage support forum



Show Posts

* Messages | Topics | Attachments

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - MarkSJ

Pages: [1]
1
SignagePlayer / Android - Live Audio Stream
« on: November 17, 2014, 04:48:21 AM »
I would like to put a live Audio stream on in the background.

At the moment, I am using a shoutcast stream, this is what I have tried:

Creating an xml file containing the shout cast stream and using the mrss component - works fine on windows and iOS (although iOS opens media player) Android, does not work - apparently, this is due to the http header provided by shoutcast.

Using a flash player to connect to the shoutcast stream with the HTML component - this works for windows but not for Android or ios (Flash player in the native browser is no longer supported in Android)

Using the audio tag in html 5 works fine on windows but on Android, you need to manualy click start as the autoplay tag is ignored and then it actually crashes signage player anyway

Using JWPlayer and the HTML component seems to work, but unfortunately due to an Android and iPhone restriction it is not possible to auto start the audio

Using an external app such as VLC, would be an option, but external apps arenot supported on Android.

So, right now, the only option I can think of is to encode in RTMP format as audio only and use the MRSS component to play the audio.

If any one has any ideas, or has been able to accomplish this, assistance would be greatly appreciated as I have spent hours and hours on this!!

2
Hi All,

Quick update on my problem with devices not reporting their status. 

If the signage controller software is running, then the player status is correctly shown.  The strange thing for me, is that the signage controller application was not starting at boot up with my Android build, even when I added the controller to start up, I could see via the notifications that the controller went through the process of kill signage player BUT then did not do the second piece of starting signage player.

So, for me the solution that works is in Auto Start application I put the controller application in twice.  This has now resolved all status reporting problems and also ensures the controller is running.

I suspect, that the issue is with the "hide status bar" app which I also run at start up.

Either way, I hope this thread is of use to other folk who may experience the same problem.

3
Sorry 367493

4
Thanks, business id is 366196  all help greatly appreciated

5
mediaPLAYERS, Hardware and accessories / Android Software Stack
« on: September 13, 2014, 07:56:55 PM »
I thought a few folk might be interested in our current hardware/software setup.  It is of course a work in progress right now and thoughts, ideas etc for the community are most welcome.

Android Hardware: Rooted Generic Rockchip based quad core TV Stick

Software:

Signage Player
Signage Controller
Auto Reboot (I know in theory signage controller software should do this)
Hide Status Bar App (note, root required) fullscreen app seemed to work ok on some devices but not all
WiFi auto login app (for the sites that prompt via webpage for internet login)
Auto Start (I know signage controller should do this)

Additional thoughts:

Kiosk Lock - prevent any other applications from running and password protecting the OS
Monitoring app. to augment MS monitoring, email alerts, network history etc
Remote control of player
Remote screen shots

Maybe some of these features are already in the MS Roadmap for Android?

I have to say, I am extremely happy with the MS Product line and Support and gladly recommend to others reading this post.

6
The players running the content is not a problem, the players all work very well with no issues.

The problem I have is monitoring of the players as their status constantly shows as red.  Even if the players intermittently sent a "green" status, there is no player history capability via the monitoring screen.

Current options as I see it right now:

1. MS fix the issue of players incorrectly reporting status / MS provide a historical report of player network status
2. Using the proof of play AD analytics, I can already use the report to get a basic idea of player status over time
3. I use an additional application like kioskmonitor or sitekiosk.com or kioware

As it stands, I am thinking about going the 3rd party application option as this other added advantages (such a locking down the device)








7
Ok, so a little more information on further testing:

1. All my players are located in Thailand. Latency to pluto.signage.me is around 370ms, traceroute is 18 hops.
2. I experience the same problem regardless of OS (now tested on windows, iOS and Android)
3. I will initially get a status of green when a player starts, then after a few minutes the status goes red and stays that way
4. All players are connected directly to the internet some WiFi, some hard wired (makes no difference)
5. This is happening with multiple ISP's (AIS, 3BB, True and TTT)
6. This is happening in multiple locations across the city
7. When support add a player in the US to test everything appears to work without issues.

Everything points thus far to an issue connecting from Asia to the US.

Are there any other folk having the same problem with players connecting from Asia ? (Thailand, Malaysia, India etc etc) ?
Can anyone offer up any suggestions at all as to what I can do next? (short of putting in a private server)

Obviously, I am concerned about being able to see the live status of players and also reporting on the proof of play, sending new content etc etc

Thanks

/Mark

8
Has anyone else seen this problem?

I have a number of Android players (4.11 rockchip based) all are connected directly to the public internet. Some never show a status of "green circle" when playing, others will show green circle for perhaps 10 minutes then show red.

I only get this problem with Android players.

Could this be a latency issue? I am based in thailand using the default server (which when setting up a new player I haven to press the connect button 4/5 times for it to work)

Any help appreciated.

Thanks

Mark

9
SignageStudio / Re: Multiple Time Lines / Screens Advice Please.
« on: August 19, 2014, 02:28:46 AM »
Thanks all for your advice and assistance (particularly Anoop) I think with the pointers and suggestions from the community I have a plan that should work.

Thanks

Mark

10
SignageStudio / Re: Multiple Time Lines / Screens Advice Please.
« on: August 18, 2014, 08:46:55 PM »
Ok, I tested the collection component, unfortunately it doesn't support videos so I would need to create a scene for each one. Messy, but possible.

Another more simple thought I had was to host the video files on an external server, then just update them as needed. Two things I need to check:

1. Are external videos cached
2. If they are cached, how long are they cached for before checking for a new file version.

Mark

11
Is there any update on this working on Android? If not, then can I suggest it is added to the html video that the functionality is player dependent.

12
SignageStudio / Re: Multiple Time Lines / Screens Advice Please.
« on: August 17, 2014, 07:13:08 AM »
Ok, I am not an Enterprise user at this point evaluating the signage options. This does seem like another good reason to get the enterprise version. Thanks for the assistance.

13
SignageStudio / Multiple Time Lines / Screens Advice Please.
« on: August 16, 2014, 06:39:05 PM »
I have 10 stations, each station plays 2 rotating time lines.  One of the time lines is common to all stations, the other is unique to each station, each station is running its own individual campaign.

If I wish to update the content on the time line that is common to all stations, currently I would need to update the timeline in each campaign ie 10 different changes.

I am sure there must be a way of organizing my stations and timelines better to reduce this regular updating (especially as content changes weekly) so that I only make the change in one place.  Any ideas, thoughts and pointers greatly appreciated.

Thanks

Mark

Pages: [1]
Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines