MediaSignage support forum

community support => SignagePlayer => Topic started by: ale-signage on January 20, 2012, 08:54:54 AM

Title: SWF AS3 xml reading problem
Post by: ale-signage on January 20, 2012, 08:54:54 AM
Good morning,
 I have and SWF file pointing to an xml positioned in a http://localhost address. It works if I open it directly from a browser (in the signage studio caching directory) but it doesn't if I open it with the signage player, even if it has "trust content" selected. I have plenty of swf files working on this system in the same way, I can't understand why this one doesn't...any idea?
Regards,
Alessandro
Title: Re: SWF AS3 xml reading problem
Post by: digitalzack on February 20, 2013, 01:11:20 AM
i know it's a long time ago you posted this - but because i've also swf file with xml i can help (maybe) - and maybe other persons need this information also

you have to give the permission on the station you want to play it in the flash settings - http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html

after that it will load the content from the xml file
Title: Re: SWF AS3 xml reading problem
Post by: Bergerad on May 22, 2013, 11:49:28 PM
Can u explain in more detail please.
I'm also using a swf that is pointing to an xml file.  I'm using this as an image scroller. Works fine on my desktop but....
Can I upload this logic to my resources and assign to a channel?
This file contains multiple instructions, is studio capable of doing this?  Thanks!