April 17, 2021, 10:57:35 PM
Welcome, Guest. Please login or register
News: Join us for a FREE Webinar this Thursday at http://webinar.digitalsignage.com

MediaSignage support forum



Show Posts

* Messages | Topics | Attachments

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - indiaexcite

Pages: [1]
1
Dear Admin,

git@github.com:born2net/studio-lite.git

I am using the above code.

Thank you very much for your support.

With warm regards,
Venkat C

2
born2net/studio-lite

git@github.com:born2net/studio-lite.git

3
Dear Admin,

Thank you for you support.

I changed node version to 6.9.0  and angular/cli to 1.0.0 and gulp on 3.9.1.

​Now it is showing the following error
--------------------------
The "@angular/compiler-cli" package was not properly installed.
-------------------------
Could you please confirm which package of compiler this application needs?

Sorry if not clearly understood your previous post.

With warm regards,
Venkat C

4
as mentioned, please use the versions indicated as the source code was written with said versions of nodeJS.

otherwise, you will need to rewrite the source for nodeJS 12

best regards

-ADMIN

As advised the apt versions are installed.
No errors.

Port opened.

Now how do I install studiolite and run from my server!?

Kindly advice.

Regards,
Venkat Chinniah

5
Dear Admin,

Thank you for your response.

installed:

Node: 12.3.0
NPM: 6.12.0
Typescript: 2.4.0

Installed the provided packages and opened the port, there is a problem when running npm install and it shows some application errors like this for example:
--------------------------------
gulp[4799]: ../src/node_contextify.cc:649:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x9d8da0 node::Abort() [gulp]
 2: 0x9d8e27  [gulp]
 3: 0x9cc94f node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp]
 4: 0xba4edb  [gulp]
 5: 0xba5a62 v8::internal::Builtin_HandleApiCall(int, unsigned long*, v8::internal::Isolate*) [gulp]
 6: 0x13726d9  [gulp]

------------------------------------

If you require I shall provide error logs further on this issue to identify what is causing it not to run.

Thank you very much for your support.

Kindly guide me in this Regard.

Thank you.

With warm regards,
Venkat C

6
My Server:
Debian version 9 on - linux server

I have installed the required packages from the provided git repo and angular.js, and did the following steps:

1) Upgraded node to 12.3.0 and npm to 6.12.0 LTS
2) Installed typescript 2.4
3) Installed angular/cli@latest
4) Opened port 4208 from firewall

Now I ran the command npm install and it ran into some errors which are listed below:

----------------------------------------------------------

silly build create-error-class
info linkStuff error

silly build make-error
info linkStuff make-error

silly build plugin-error
info linkStuff plugin-error
silly linkStuff plugin-error

 silly build silent-error
info linkStuff silent-error
 silly linkStuff silent-error

silly build error-stack-parser
info linkStuff error-stack-parser
 silly linkStuff error-stack-parser
                                            ......

error code ELIFECYCLE
error errno 134
error studioweb  postinstall: `npm run dev`
error Exit status 134
 error Failed at the studioweb  postinstall script.

----------------------------------------------------------------------------

Any suggestions required to sort the errors please.

Thank you.

Regards,
Venkat C

Pages: [1]
Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines