September 20, 2020, 08:29:30 AM
Welcome, Guest. Please login or register
News: Stay up to date with everything that's happening at http://twitter.digitalsignage.com

MediaSignage support forum



Author Topic: Player suddenly stopped and will no longer work  (Read 3132 times)

maverick3n1

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Player suddenly stopped and will no longer work
« on: December 21, 2010, 06:11:58 AM »
Linux Ubuntu 10.0.4

Player was running fine, then we ended up deleting the registration on the server side.  The player crashed from that deletion, and now every time it loads, the player window that allows you to start, pause, unregister etc.. shows up grey and it doesn't load any swf files.  I've tried uninstalling and reinstalling the player.  I tried uninstalling the player and AdobeAIR and reinstalling both.  Same results all around.  I never get the opportunity to register or unregister it as it never runs the swf files that have the configuration settings in it.  Any suggestions?

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
  • Karma: +35/-8
    • View Profile
Re: Player suddenly stopped and will no longer work
« Reply #1 on: December 21, 2010, 02:40:55 PM »
Be sure to delete all Cache.


You need to delete the SignagePlayer cookie.
To do this.

1. Close the SignageController
2. Close the SignagePlayer
3. Delete the dir:

rm -f -r /home/root/.appdata/SignagePlayer.* or /root/.appdata/SignagePlayer.*

(that is its installed under the user root)

Always glad to help,

Eddie - MediaSignage.com


maverick3n1

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Player suddenly stopped and will no longer work
« Reply #2 on: December 21, 2010, 05:06:45 PM »
I did as you asked, deleted the folder (although I was unable to view the contents of root, but I was able to remove the folder you suggested using sudo).  Ran the program again, and same problem.  Do I need to delete that folder and then re-install the signage software?

maverick3n1

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Player suddenly stopped and will no longer work
« Reply #3 on: December 22, 2010, 07:32:14 AM »
I didn't run the command as bash, so it appeared that the command was successful, but it wasn't.  I've since run the command as bash, and it solved that problem.  I have one other problem however.

I set this same content player up like it would be at a client's location.  No keyboard or mouse plugged in.  Just plugged in a monitor, network cable, and power.  Turned it on, and left my computer monitor powered on.  Approx 10-20 minutes in, the content just stops playing.  Screensaver is disabled, and so is all power management features.  I ran it all night last night, and when I turned the monitor on this morning, it was fine.. but it ran with the keyboard and mouse plugged in.  Even though I didn't move the mouse or keyboard, the act of turning my monitor on may have triggered it to continue playing if it had paused.  This morning however, when I set it up as a standalone with no mouse and keyboard, it cuts out after it loops the content 1-2 times.  The content is currently 6 minutes long, but should loop indefinitely like it did from last night until now.

Any suggestions as to why it would stop playing if there is no keyboard and mouse plugged in?  I was told by support last night that it was a known bug in ubuntu 10.0.4, and that they fixed it by adding a script to the startup that moved the mouse arrow for 3 seconds.  I checked, and that script is already in place, yet hasn't resolved this problem.  Any help would be appreciated.

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
  • Karma: +35/-8
    • View Profile
Re: Player suddenly stopped and will no longer work
« Reply #4 on: December 22, 2010, 08:21:55 AM »
The script is in place, but you probably don't have the XTE Xautomation installed so the script does not take effect

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines