August 15, 2020, 08:29:35 PM
Welcome, Guest. Please login or register
News: Stay up to date with everything that's happening at http://plus.digitalsignage.com

MediaSignage support forum



Author Topic: Studio-Lite npm install error.  (Read 296 times)

DoktorFleisch

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Studio-Lite npm install error.
« on: July 13, 2020, 07:11:06 PM »
Hello dear support,

I tried to get the studio-lite (from github) running locally.

All went well with these steps:

git clone github.com/born2net/studio-lite.git
cd studio-lite
npm install -g @angular/cli@latest

but, npm install wont work.

Here is the errormessage I get:

> studioweb 0.1.774 postinstall /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite
> npm run dev


> studioweb 0.1.774 dev /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite
> npm run x_cssDev && ng serve --port 4208 --aot false


> studioweb 0.1.774 x_cssDev /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite
> gulp cssDev

[19:23:27] Using gulpfile /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite/gulpfile.js
[19:23:27] Starting 'cssDev'...
[19:23:27] The following tasks did not complete: cssDev
[19:23:27] Did you forget to signal async completion?
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! studioweb 0.1.774 x_cssDev: `gulp cssDev`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the studioweb 0.1.774 x_cssDev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-07-13T17_23_27_487Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! studioweb 0.1.774 dev: `npm run x_cssDev && ng serve --port 4208 --aot false`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the studioweb 0.1.774 dev script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-07-13T17_23_27_497Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! studioweb 0.1.774 postinstall: `npm run dev`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the studioweb 0.1.774 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-07-13T17_23_27_516Z-debug.log

The live-chat-supporter could not help me, and he said that the "installing-person" will be available at 3 pm.
But I am living in Germany, and because of the time shift, 3 pm is 11/12 pm at my time (that is to late for me^^), so I hope someone could help me in this forum.

Thank you in advance and stay safe!

ps. I had to remove the @ after studioweb in this post, otherwise I could not post.

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5078
  • Karma: +35/-8
    • View Profile
Re: Studio-Lite npm install error.
« Reply #1 on: July 14, 2020, 12:27:40 AM »
the original code was developed using older version of nodejs and npm and using linux os.  the code is given as is and assumes you know javascript, nodejs and angular framework - this way, you may adopt to the version of nodejs and npm you are using.  also,some commands in the script are linux commands so you may have issues when running this on windows - if you are using windows, modify the script to use windows command.

note that you may need to install some libraries using node install ex. node install gulp. also note that ng and gulp are linux apps that should also be installed on your development machine.

for compiling, run: npm run release_jit - this will generate the final deployment files under the directory dist. you can then do further modification on the deployment file.

for other coding issues, post your issues at our github site.

best regards

-ADMIN
« Last Edit: July 14, 2020, 12:30:01 AM by admin »

DoktorFleisch

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Studio-Lite npm install error.
« Reply #2 on: July 15, 2020, 03:26:53 PM »
Hello,

I work on a Linuxsystem, and node, gulp etc is installed. With your given command -  npm run release_jit - to compile, it wont generate a distfolder, but gives me a similar error: 

> studioweb 0.1.774 release_aot /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite
> npm run x_cssRelease && rm -r -f ./dist && npm run x_bump && npm run x_prod_aot && npm run x_sw && npm run x_rsync


> studioweb 0.1.774 x_cssRelease /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite
> gulp cssRelease

[15:49:10] Using gulpfile ~/Dokumente/sesoco/DS/StudioLite/studio-lite/gulpfile.js
[15:49:10] Starting 'cssRelease'...
[15:49:10] The following tasks did not complete: cssRelease
[15:49:10] Did you forget to signal async completion?
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! studioweb 0.1.774 x_cssRelease: `gulp cssRelease`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the studioweb 0.1.774 x_cssRelease script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/danielw/.npm/_logs/2020-07-15T13_49_10_147Z-debug.log
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! studioweb 0.1.774 release_aot: `npm run x_cssRelease && rm -r -f ./dist && npm run x_bump && npm run x_prod_aot && npm run x_sw && npm run x_rsync`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the studioweb 0.1.774 release_aot script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/danielw/.npm/_logs/2020-07-15T13_49_10_157Z-debug.log

Also, I tried those commands (found on another topic):

- npm run release_aot
- npm run release_aot_no_syn

Same errormessage.

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5078
  • Karma: +35/-8
    • View Profile
Re: Studio-Lite npm install error.
« Reply #3 on: July 15, 2020, 11:50:43 PM »
as mentioned, it uses gulp and it should be installed. install gulp using the command: sudo apt install gulp
then try to test it by running: gulp cssRelease

do you have nodejs development experience? have you used npm before?

best regards

-ADMIN

DoktorFleisch

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Studio-Lite npm install error.
« Reply #4 on: July 25, 2020, 10:35:10 AM »
Hello Admin,

gulp is installed,, by using the command "gulp --v" I got this:

CLI version: 2.3.0
Local version: 4.0.2

So, gulp has to be installed, right?

By using: "gulp cssRelease" I get this errormessage:

[11:24:38] Using gulpfile ~/Dokumente/sesoco/DS/StudioLite/studio-lite/gulpfile.js
[11:24:38] Starting 'cssRelease'...
[11:24:38] The following tasks did not complete: cssRelease
[11:24:38] Did you forget to signal async completion?
------------------------------------------------------

And no, I have no experience in nodejs development, I am new in the IT.


EDIT2:

I ran

         ng --version
         npm install --save-dev @angular/cli@latest
         ng --versionupdate angular/cli,,

and the errormessages are getting shorter after running npm run release_jit:

> studioweb 0.1.774 release_jit /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite
> npm run x_cssRelease && rm -r -f ./dist && npm run x_bump && npm run x_prod_jit && npm run x_sw && npm run x_rsync


> studioweb 0.1.774 x_cssRelease /home/danielw/Dokumente/sesoco/DS/StudioLite/studio-lite
> gulp cssRelease

gulp[8240]: ../src/node_contextify.cc:659:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x561dcff28131 node::Abort() [gulp]
 2: 0x561dcff281c7  [gulp]
 3: 0x561dcff1a271 node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp]
 4: 0x561dd0111bb7 v8::internal::FunctionCallbackArguments::Call(v8::internal::CallHandlerInfo) [gulp]
 5: 0x561dd01124e1  [gulp]
 6: 0x561dd01127db  [gulp]
 7: 0x561dd0113156 v8::internal::Builtin_HandleApiCall(int, unsigned long*, v8::internal::Isolate*) [gulp]
 8: 0x561dd08a3d19  [gulp]
sh: Zeile 1:  8229 Abgebrochen             (Speicherabzug geschrieben) npm run x_cssRelease
npm ERR! code ELIFECYCLE
npm ERR! errno 134
npm ERR! studioweb 0.1.774 release_jit: `npm run x_cssRelease && rm -r -f ./dist && npm run x_bump && npm run x_prod_jit && npm run x_sw && npm run x_rsync`
npm ERR! Exit status 134
npm ERR!
npm ERR! Failed at the studioweb 0.1.774 release_jit script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/danielw/.npm/_logs/2020-07-25T10_29_57_459Z-debug.log


EDIT3:

Ooh, and gulp cssRelease gives me this message:

gulp cssRelease[13491]: ../src/node_contextify.cc:659:static void node::contextify::ContextifyScript::New(const v8::FunctionCallbackInfo<v8::Value>&): Assertion `args[1]->IsString()' failed.
 1: 0x5614dc0bd131 node::Abort() [gulp cssRelease]
 2: 0x5614dc0bd1c7  [gulp cssRelease]
 3: 0x5614dc0af271 node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value> const&) [gulp cssRelease]
 4: 0x5614dc2a6bb7 v8::internal::FunctionCallbackArguments::Call(v8::internal::CallHandlerInfo) [gulp cssRelease]
 5: 0x5614dc2a74e1  [gulp cssRelease]
 6: 0x5614dc2a77db  [gulp cssRelease]
 7: 0x5614dc2a8156 v8::internal::Builtin_HandleApiCall(int, unsigned long*, v8::internal::Isolate*) [gulp cssRelease]
 8: 0x5614dca38d19  [gulp cssRelease]
[1]    13491 abort (core dumped)  gulp cssRelease

« Last Edit: July 25, 2020, 12:09:23 PM by DoktorFleisch »

DoktorFleisch

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Studio-Lite npm install error.
« Reply #5 on: July 29, 2020, 07:27:32 AM »
Dear Admin,

is there a way you send me the conpiled _dist folder per email? I´m stuck on this one.

Thank you in advance!

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5078
  • Karma: +35/-8
    • View Profile
Re: Studio-Lite npm install error.
« Reply #6 on: July 29, 2020, 06:12:18 PM »
we advise you to get someone with nodejs, angular background to help you out. these are basic compilation errors that can be resolved by setting up the environment appropriately.

best regards

-ADMIN

DoktorFleisch

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Studio-Lite npm install error.
« Reply #7 on: July 29, 2020, 08:53:20 PM »
Dear Admin,

as you already mentioned, these are some basic errors,, so why you can´t help me to resolve this? Or to send me the compiled dist folder to me email??

This is my first job in the IT, and I have to get this running,, so I would appreciate a more satisfying answer then "search for somebody who can fix that problem".

However.. I did everything you, and the git-website told me: Install node.js/angular/gulp where such things can´t go much wrong.

I´am using Manjaro as a Lunix-Distro.. What did get wrong??


EDIT:

MSgetstarted did run fine with npm install, and I started a angular course, and there, node.js ran fine too.
« Last Edit: July 30, 2020, 09:42:46 AM by DoktorFleisch »

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines