December 13, 2019, 08:47:52 AM
Welcome, Guest. Please login or register
News: Join us for a FREE Webinar this Thursday at http://webinar.digitalsignage.com

MediaSignage support forum



Author Topic: Bug: Catalog picture resources not being displayed on Android  (Read 628 times)

perditi0nspam

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Hi everyone,

I've seen the following bug occur across different Android boxes (6.0 and above are in use):

1) Create a catalog item which is a picture resource (either jpg or png). Assign this item to a category.
2) Create a new scene (Catalog MIME). Add a "catalog item" component and assign it the "resource" item.
3) Within one of the channels in a timeline, add a "catalog player" component and assign the previous scene. Assign the catalog player to work with the catalog.

So far this is standard. Expected behaviour would be that every "time interval" the catalog player would show a different picture. However the picture doesn't show at all. What is shown on the Android box are fields like "name", "info0" etc. but no picture resources.

The timeline preview shows that the catalog player plays the picture resource correctly.

Things I've tried to resolve this:

1) Resize the picture (resource) to be the same size as the screen divison for the timeline.
2) Resize picture (resource), screen division AND scene to be the same size.
3) Played with background/appearance settings for catalog player, catalog item (under the scene) and the scene itself.
4) Resetting and clearing the cache for the Android players.

Any ideas what could be causing this and how to resolve it?

Thanks!
« Last Edit: June 09, 2019, 01:30:08 PM by perditi0nspam »

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5016
  • Karma: +35/-8
    • View Profile
Re: Bug: Catalog picture resources not being displayed on Android
« Reply #1 on: June 10, 2019, 07:01:20 AM »
as i understand, you are using Android OS version 6 - what is the player software version used?

can you try this beta version of the android player: http://galaxy.signage.me/Code/Install/apk/6.3/CloudSignagePlayer.apk


perditi0nspam

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Bug: Catalog picture resources not being displayed on Android
« Reply #2 on: June 10, 2019, 12:12:16 PM »
Hi, thanks for the quick reply.

I'm using both Android 6 and Android 8. I installed the beta client you provided, it didn't resolve the issue. In fact there are some objects that appear in the stable release that don't work in the beta client, i.e. a .png resource.

Edit:  The issue is resolved thanks to the support staff's help, and the solution consists of two parts:  Installing the beta client, and also ensuring you have the hardware resources on the Android box for the graphical changes on the timeline. The beta client performed as expected on the stronger Android box, but gave a worse experience on the lower end box. Apparently S905 chipsets aren't heavy lifters! 
« Last Edit: June 10, 2019, 10:42:21 PM by perditi0nspam »

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines