April 24, 2019, 04:19:51 AM
Welcome, Guest. Please login or register
News: Join us for a FREE Webinar this Thursday at http://webinar.digitalsignage.com

MediaSignage support forum



Author Topic: XML Player Not refreshing with recent data  (Read 462 times)

Foodsignageadmin

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
XML Player Not refreshing with recent data
« on: January 25, 2019, 08:05:33 AM »
Hi All,
First time posting here but I'm out of options and need to get this resolved asap, so I figured this group would be the place to go!

Issue:
We have over 20 sites that utilize what we call templates, we've created a bunch of "concepts" and copy them to new sites as campaigns when they start up. From there they change images and wording etc. The main problem here with only 1 site is that the XML data is supposed to pull an Item name, description, and up to 3 icons. What's happening is when the timelines play they are either not loading the new data, or it's playing with lingering icons or verbiage. Now before you go saying well the data in the XML URL is wrong, it's not. I can verify this by going to the URL and checking the XML data which is displaying the correct data. Support seems to think that i just need to clear the cache in %appdata% which ok yes works, but this is not a viable solution for every scheduled timeline. Hitting the clear cache button in signage studio does update the player to the correct data. This is hit and miss on any amount of the 15 players we have at this account, sometimes it happens other times it works as it should. We're currently on version 5 and studio v5 as well. I have tried updating both the signage studio and the player versions to the latest with no joy. I've tried clearing the cache, i've also tried installing on a freshly imaged windows 10 player and can replicate the issue.  The way our XML player's are setup there is a scene that's created that points to the item name, description, calories, and icons 1-7 if they choose to use that many. On all of our other accounts if data is void or not in the XML nothing is displayed on the scene. What makes things worse is the fact that in signage studio it sometimes looks correct, but the players do not , they'll still be displaying last nights scheduled icons or imagery. Help!

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 4932
  • Karma: +35/-8
    • View Profile
Re: XML Player Not refreshing with recent data
« Reply #1 on: January 30, 2019, 07:07:11 PM »
the tech support whom you have worked with was able to replicate the issue and had already reported this to our dev team.  unfortunately, we cannot give you an estimate on how soon this can be fixed as the devs are also working on other fixes that would be part of the next release.  we would therefore recommend that for the meantime to consider the workarounds recommended i.e. having a the same number of XML entried with the description field containing blank and the image field point to a transparent image by default which seems to be easier to do programatically. this would be better than having the player cleared of its cache via studio's Clear Caching function as this would require manual intervention.

best regards

-ADMIN

Foodsignageadmin

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: XML Player Not refreshing with recent data
« Reply #2 on: January 31, 2019, 01:25:54 PM »
I don't think you guys even understand the issue. We run the exact same setup on over 20 locations without this issue. They use the same web server, with the same exact setup. Something is weird with just this one site, and i don't understand why only 1 site would be doing this. This doesn't seem like an issue that needs to go to development when your support team can't even tell me what the issue actually is. Can you please reword your recommended workaround as it's not very good english and i'm not sure what you mean. Our XML players have always pointed to an XML scene in which calls available XML data from our webserver. If the XML data isn't present the data hasn't shown in the past, for some reason it is now and only for 1 location. The fact that it's holding onto old xml data from the night before tells me something is stuck, this happens every night to random players and is resolved by clearing the cache. Is there any scripted function to clear the cache that we can write?

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 4932
  • Karma: +35/-8
    • View Profile
Re: XML Player Not refreshing with recent data
« Reply #3 on: February 01, 2019, 07:05:02 AM »
to give you a better idea what is happening and when it gets "stuck", please see the following simulation: https://www.screencast.com/t/mTN9Smo5R - note that if the issue can be replicated, it means its actually happening on all players.

please get in touch with RON through chat  as he may discuss this in more detail.

- ADMIN

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines