December 09, 2018, 10:50:05 PM
Welcome, Guest. Please login or register
News: Stay up to date with everything that's happening at http://plus.digitalsignage.com

MediaSignage support forum



Author Topic: Video feed no longer working  (Read 180 times)

MrBassMan

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Video feed no longer working
« on: November 27, 2018, 02:54:13 PM »
A long working video feed has stopped woring in the last few days. The url for the feed is shown below:

Internally i use the hhtp prefix followed by the internal IP address, followed by:
/zm/cgi-bin/nph-zms?mode=jpeg&monitor=1&scale=100&maxfps=30&buffer=1000&user=guest&pass=guest

If anyone wants to test signagestudio with this feed, you can access it using www  new-quay-shop.co.uk : 8081 followed by the string above. This is NAT'd to the internal pi by a router.

At that address is a raspberry pi running zoneminder which is taking a feed from a webcam. It's done like this as the pi can handle multiple connections better, is (relatively) more secure than the webcam and is self limiting on the number of simultaneous connections.

I have tried various things including using the HTML component pointed at the zoneminder monitor page, the video component using the URLs above etc. The html component shows the surrounding text but still does not display the video. Both the zoneminder monitor page and the direct link to the image work fine under Chromis on a Windows PC.

Anyone have any ideas or suggestions?

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 4874
  • Karma: +35/-8
    • View Profile
Re: Video feed no longer working
« Reply #1 on: November 30, 2018, 04:14:27 PM »
If the built in HTML and browser component doesnt work with your URL, you can use the external app firefox option  as long as you are using a windows based player.

http://www.digitalsignage.com/_html/video_tutorials.html?videoNumber=FireFox

MrBassMan

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Video feed no longer working
« Reply #2 on: December 08, 2018, 06:12:23 AM »
I am afraid the player is an android stick with an attached HDMI tv in the shop window.
This used to work, has something changed in the studio in the area of handling video images?

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines