October 21, 2020, 01:00:17 AM
Welcome, Guest. Please login or register
News: Stay up to date with everything that's happening at http://twitter.digitalsignage.com

MediaSignage support forum



Author Topic: MRSS images not showing because the image files are getting renamed with a + sym  (Read 3196 times)

AndrewL

  • Full Member
  • ***
  • Posts: 130
  • Karma: +6/-0
    • View Profile
I was advised in live chat to put this as a forum post.

I have an MRSS feed that I use for the Custom RSS Player and found that 20% of my images were not showing up in the studio or player. Upon further inspection I found that the studio would cache my images but would rename them adding a '+' symbol to some of them. Each image that had a plus symbol added to it would show up as a blank broken image in the studio and player.

So to make this very clear:

Sample:
my image is named: a.png
When the software downloads and caches it, it calls it: a+n.png

Real life example:
Mine: 390be73797e885a250394b7d12ad1fb3.png
Theirs: BHIEfgQsBMUERgQuA9AERgP7A+I.png

All images are renamed, which is fine, but the ones that are renamed with a plus symbol do not play. Please fix ASAP!

AndrewL

  • Full Member
  • ***
  • Posts: 130
  • Karma: +6/-0
    • View Profile
I did some further testing to see if it was because my MD5 32 character image titles were too long. I shortened it to 22 characters but still plus symbols were added to some during the caching and renaming.

I also have a Screenfeed account for picture image entertainment and it is also renaming their images with plus signs causing blank spots in the presentation. Please - high priority review this.

AndrewL

  • Full Member
  • ***
  • Posts: 130
  • Karma: +6/-0
    • View Profile

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5093
  • Karma: +35/-8
    • View Profile
yes we opened a bug and will look into it on next release.

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines