December 07, 2019, 10:08:58 PM
Welcome, Guest. Please login or register
News: Stay up to date with everything that's happening at http://plus.digitalsignage.com

MediaSignage support forum



Author Topic: Error duplicate entry for primary SQL key showing up in Signage player  (Read 3239 times)

bsergon

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Hi,

we are using your solution, the Signage Studio Pro for preparation of the content and then the Signage player for displaying the content. Mostly the solution is working without any problem.

In Signage Studio Pro we are using one Timeline and five channels and in each of these channels we are using the HTML component option and we are displaying the content of one URL/internet page. Time to time (mostly is working very well) happens, that on refresh/sync, one of channels (also randomly, not always the same channel) don`t display the content of the URL, but an error, which contains a text like this:"Duplicate entry ... for key Primary SQL=insert into".

Please, can you explain why this error is showing up? What we are doing wrong? Is maybe there some option, setting, that we have to set/change?

Thank you very much in advance for the answer and help.

BR, Borut

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5010
  • Karma: +35/-8
    • View Profile
is this error coming from the HTML component? can you post an image?

bsergon

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Yes, the error is coming from the HTML component. I will try to do take a printscreen when the error shows up. Is this a known bug, how we can avoid it?

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5010
  • Karma: +35/-8
    • View Profile
never seen that error...
are you on Windows Player?

bsergon

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
No, this error is showing up only on Android player.

bsergon

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
This is the screenshot of the error: to-interni-marketing.com/index.php?option=com_content&view=article&id=8

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5010
  • Karma: +35/-8
    • View Profile
sorry but can u post the whole screen? we need to see the alert windows as well

bsergon

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
This is it. This is the screen (the whole screen) that the user see on the screen. There is no additional error or alert window. Instend of the content, the error is displayed. BR, Borut

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5010
  • Karma: +35/-8
    • View Profile
I believe this is coming from the web site... if you try a diff domain it goes away?

bsergon

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
No, the problem is not coming from the web site. The web site is working and the content on the web site (if you opne the URL in the web browser) is working just fine. Also the preview in teh Signage Studio is always working fine and is showing the content. The problem is showing only in the Signage Player.

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines