September 21, 2017, 10:49:45 AM
Welcome, Guest. Please login or register
News: Join us for a FREE Webinar this Thursday at http://webinar.digitalsignage.com

MediaSignage support forum



Author Topic: Posting the NEW Video Tutorials on my website?  (Read 64652 times)

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Posting the NEW Video Tutorials on my website?
« on: April 17, 2015, 09:25:16 AM »
I was able to get the github files, but could not find any way on how to implement them on my webpage.

Can I get instructions on how to do this?

Thank you,
Robert

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 4701
  • Karma: +32/-7
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #1 on: April 17, 2015, 10:34:02 AM »
You need to host the entire component and look at Google console for possible errors.
For further debugging I recommend you hire a JS freelancer.

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #2 on: April 17, 2015, 10:40:21 AM »
When you say host the entire component.... How do you add it to my HTML page?

With the old tutorials you supplied the code needed to embed the tutorials onto an existing HTML page. That what I'm looking for with the NEW one.

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 4701
  • Karma: +32/-7
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #3 on: April 17, 2015, 11:24:16 AM »
you would want to fork and download the source for the new component from https://github.com/born2net/videoTutorials
as for modification and hosting I recommend getting a JS dev as it's beyond our support.

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #4 on: April 17, 2015, 11:32:24 AM »
I downloaded the source files from github.... But what do you mean by "fork"?

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 4701
  • Karma: +32/-7
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #5 on: April 17, 2015, 01:21:24 PM »
yes download is fine, fork is only if you wish to modify and share on github

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #6 on: April 20, 2015, 07:04:14 AM »
I would be nice to get a step by step instruction on how to implement the Video Tutorials on your own web site.

criley

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 598
  • Karma: +14/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #7 on: April 20, 2015, 10:46:57 AM »
The problem with a step by step tutorial is that it would take their time to try and teach you HTML programming assuming they know how to program themselves. Of course you can always find a course online that can give you step by step instructions on how to build a website with HTML/JavaScript. If that is not something that you are will to take on right now, as they have suggested, you are encouraged to find a programmer that is experienced in web design that can build your site for you. If you wish, I can be of service and you can email me directly.

Chris

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #8 on: April 20, 2015, 12:34:43 PM »
I am proficient in HTML and CSS. I know a little javascript if I see an example I can understand it.

Once I downloaded the files from Github, I don't understand how they related to use them onto a html page on my website.

Maybe if you can send me an HTML sample page that uses the video tutorials(Github files), then I can look at that to create my own page.


criley

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 598
  • Karma: +14/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #9 on: April 20, 2015, 12:38:08 PM »
Just look at the video tutorial page. It's is just what you ask. Click on view source and see how it is incorporated. It should then take you a minute to put it on your site and then what ever time you need to customize it to your liking.

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #10 on: April 21, 2015, 12:04:42 PM »
Ok, I added the code from your video tutorials page to mine. Made some URL path adjustments.

When my page loads I see the framework but is just says "Loading" where the video list should be.

I'm getting one error in the google console saying that the "videos.json" file is missing. I confirmed that it is in the proper directory.

It reads.........

Failed to load resource: the server responded with a status of 404 (Not Found)         http://www.mydomain.com/zss-tutorials/videoTutorials/_data/videos.json?_=1429641872161

Can you help me with this?

criley

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 598
  • Karma: +14/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #11 on: April 21, 2015, 12:59:20 PM »
You'll have to send me the url to the site so i can look at it.

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #12 on: April 21, 2015, 01:02:50 PM »

criley

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 598
  • Karma: +14/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #13 on: April 21, 2015, 01:54:58 PM »
I see the directory "_data" exists in the "videoTutorials" directory. Your URLs look ok. So of course this 404 message is stating that the file does not exist. I know it's a dumb question, but is the file (videos.json) there under the "_data" directory with the XML files?

If it does exist, then it is probably because your server is not allowing the loading of json files. I am assuming you are on a windows server from the error messages I have seen. Try adding the following to your Web.config file in your IIS settings.

  <system.webServer>
    <staticContent>
      <mimeMap fileExtension=".json" mimeType="application/json" />
    </staticContent>
  </system.webServer>


If you are not on a Windows box, then I am not sure why your system is not loading the json files.
« Last Edit: April 21, 2015, 01:57:05 PM by criley »

rknight

  • Jr. Member
  • **
  • Posts: 71
  • Karma: +0/-0
    • View Profile
Re: Posting the NEW Video Tutorials on my website?
« Reply #14 on: April 22, 2015, 06:42:48 AM »
Yes I am using a Windows Server. So I uploaded the files to one of my UNIX Servers, and now I see the video tree and able to play the videos.

you can see it here: http://www.zingerdigital.com/zss-tutorials/

Now there's only a couple things that I need to fix... The Close "X" button is aligning far to the right, Can't find the fonts you are using, and not finding the tree_icon.png

The tree_icon.png was not included in the files from gitHub.
I can not seem to find where the path to the "tree_icon.png" so I can change it. Where can I find it?

How can I get the fonts to looking the same as on your site. I see the path for the fonts...."//netdna.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.css"
Is this correct or does it need to be something else?

Thank you,

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines