September 20, 2020, 09:48:56 AM
Welcome, Guest. Please login or register
News: Stay up to date with everything that's happening at http://twitter.digitalsignage.com

MediaSignage support forum



Author Topic: BUG: ERROR: 22008: date/time field value out of range: "11/31/2014 12:00 AM"  (Read 5827 times)

JMH

  • Full Member
  • ***
  • Posts: 203
  • Karma: +4/-0
    • View Profile
I get this error: ERROR: 22008: date/time field value out of range: "11/31/2014 12:00 AM"
It occures when I try to save, making the Lite unusable at this time...

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
  • Karma: +35/-8
    • View Profile
yes we are fixing the error, Date issue which we just ran into due to Oct 31 + 30= Nov 31 which does not exist :)

JMH

  • Full Member
  • ***
  • Posts: 203
  • Karma: +4/-0
    • View Profile
Oke, thanks for the heads up  :)

GCR

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Hello,
    Any update on when this will be fixed.... I am receiving a similar message  ERROR: 22008: date/time field value out of range: "13/11/2014 12:00 AM". This is on a local studiolite version that I downloaded from git.

Thanks,

JMH

  • Full Member
  • ***
  • Posts: 203
  • Karma: +4/-0
    • View Profile
Do you have the newest version of StudioLite? The problem was solved for me, so perhaps you need to update the Lite version.

GCR

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Hi JMH! I though so; just pulled it from git the other day. The projects I created in the web app are fine; just a problem with this "error" version I pulled from github. Maybe I did not grab the right fork. I am a ruby-rails full-stack developers; so still getting spun up on Node.js.  I did npm studiolite update ~ but that didn't really do anything.  I will look at how I pulled it initially.  :o  You know if GitHub is updated with the latest fixes?

thanks,
   

GCR

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
I definitely don't have the updates...  I am on version 1.4.28.  And in Github I can see that Pepper.js does not have the updated date structure. I just updated manually for now.  Would be interested to see how to get the "node update" command to work ~ it cant find the update command and have tried the node directory (usr/local/bin)? Or what version npm install studiolite is pulling.

thanks

admin

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
  • Karma: +35/-8
    • View Profile
just run:

Code: [Select]
npm update studiolite

and version should be 1.1.56

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines