February 25, 2020, 04:27:48 AM
Welcome, Guest. Please login or register
News: Join us for a FREE Webinar this Thursday at http://webinar.digitalsignage.com

MediaSignage support forum



Author Topic: rss_caching.xml  (Read 2480 times)

AndrewL

  • Full Member
  • ***
  • Posts: 130
  • Karma: +6/-0
    • View Profile
rss_caching.xml
« on: May 22, 2014, 08:25:41 AM »
Hello MS,

I have been encountering some issues with custom rss feeds not showing previously cached images when the internet connection is lost potentially after a day or longer. If I lose connection during the day randomly but get connected the same day I do not lose caching - it seems to be a longer internet outage time cache loss.

I have done some testing by killing the internet connection, rebooting the player and not connecting upon start up and the rss items seem to continue to work fine off of the cache

What I have noticed however, is the file rss_caching.xml (located in the appdata - signageplayer - local store) has a very odd behaviour when or if being created.

For example:
  • it may or may not get created when running a custom rss feed for the first time on the player (windows 7).
  • I have forced the file to get created by 'clearing cache' in the signage studio or by stopping the player and starting the player, but then if I delete the xml file manually from the folder it seems I have to wait a short bit to be able to again force the creation of a new one.
  • In the meantime, the signage player still maintains the cached details - as if it is stored in a tmp file somewhere else entirely and then copied into that file location for a more permanent storage? Which could explain the loss if the tmp file is never converted or copied into the permanent file and then the tmp file kills itself especially after a player reboots itself after a day or two of no internet
  • I also notice that the xml file has the following setting expiredTime="21600".

So Im not entirely sure what is going on, if perhaps the code to create the rss_caching.xml file is getting hung up at some point which causes the long term caching loss, but that is my research into the problem - I hope this helps to diagnose the issues.

Thanks,

Andrew

AndrewL

  • Full Member
  • ***
  • Posts: 130
  • Karma: +6/-0
    • View Profile
Re: rss_caching.xml
« Reply #1 on: May 31, 2014, 05:25:21 AM »
Any confirmation that this has been added to a bug report?

RSS is important to us...

vdmidia

  • Jr. Member
  • **
  • Posts: 79
  • Karma: +0/-0
    • View Profile
Re: rss_caching.xml
« Reply #2 on: July 02, 2014, 12:17:27 PM »
Same happens here...

android should not also work without internet? I did a test here, to try to simulate what some customers are reporting, disconnected the router from the internet. then the wifi is connected but no internet.
The result was:
- Videos are freezing and losing frames;
- The images of the RSS that were being displayed (and were already in cache) are gone.  (think this a bug)  its very important to us too.
- Some clients report that even connected to the internet in some wifi networks the player does not start. changing the wi-fi network (taking the unit somewhere else) starts normally. (What can cause this behavior?)

Android 4.2.2 and 4.1tested... same thing heppens. (on 4.1 persist the "flash frame" between video transitions)
« Last Edit: July 02, 2014, 12:20:43 PM by vdmidia »

vdmidia

  • Jr. Member
  • **
  • Posts: 79
  • Karma: +0/-0
    • View Profile
Re: rss_caching.xml
« Reply #3 on: July 03, 2014, 07:20:34 AM »
Hummm. See the response i receive from MS:

Quote
rss feeds will go out without internet. only cache videos and images will remain

Well, that does not fulfill the purpose. And it was not so. Thus when there are intrnet campaigns with parts missing. All other software Digital Signage make this permanent cache, only exchange where the RSS is updated.

It would be very useful if well done, with caching RSS permanently, even when no internet.

Otherwise, the cache does not solve any probelma.
« Last Edit: July 03, 2014, 09:35:43 AM by vdmidia »

AndrewL

  • Full Member
  • ***
  • Posts: 130
  • Karma: +6/-0
    • View Profile
Re: rss_caching.xml
« Reply #4 on: July 03, 2014, 01:02:31 PM »
Hey Vdmidia,

I had a good chat with their support after a post from admin on one of my other rss strings about how it will cache RSS. They put in a bug fix request and at first glance version 4.15.24 seems to have fixed the RSS feeds from instantly disappearing upon disconnection from the internet (windows 7). I will be doing some more testing for xp and android over the next week when I get a bit more time - but it looks like they are on the right track.

MS - could you share what you are up to between versions? 4.15.20 vs 4.15.24 for example... your last update to the live doc was in October of 2013!

Thanks,

Andrew

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines