December 02, 2021, 03:34:03 AM
Welcome, Guest. Please login or register
News: Join us for a FREE Webinar this Thursday at http://webinar.digitalsignage.com

MediaSignage support forum



Author Topic: Problemas con el Android Player  (Read 3535 times)

ireirenene

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Problemas con el Android Player
« on: August 12, 2013, 05:09:29 AM »
Hi!

I'm proving an Android player and I have some problems that I can not solve. The Android Player has: Android 4.1 CPU Dual Core ARM Cortex A9 + Quad Core GPU, HDMI connection 1080p Full HD, 1GB DDR3 RAM memory, 4GB Storage memory, Wifi 802.11 b / g / n connection to Internet.

If only plays a video, it plays more or less well, although sometimes starts playing the video in small size in the corner of the top left of the screen. What is the problem? And what solution I can apply?

If you play two or three divisions of display (video sequence + RSS + Flash) will not play properly. Even the Android application crashes or closes. This is because the Android device is not suitable?

Many times in the transitions between videos (Video 1/Transition/Vídeo 2) shows a few frames from Video 1 on the Video 2 in full screen (although neither the one nor the video Video 2're playing full screen). And it always happens that the videos play full screen. I have found that the time sequence of changes match videos that are not on each other. But nothing.
Also, this happens to me on Android Player and Windows players.
May be due to the frames per minute of screen?
Is there a solution?

I need your help!
thank you very much!

mediaboy

  • Newbie
  • *
  • Posts: 38
  • Karma: +3/-0
    • View Profile
Re: Problemas con el Android Player
« Reply #1 on: August 12, 2013, 06:27:36 AM »
Hi ireirenene,

We've also had this issue which I reported to MS Tech Support back in May. From our experience, it mainly appears to happen with video clips that are loaded on frame one of a timeline. In terms of a workaround which seems to 'fix' the issue, we discovered something ourselves – simply offset the video by one second (i.e. start it on frame 2 of the timeline). For some reason this consistently fixed the scaling issue. Wether this gives the ‘stage’ enough time to be aware of each ‘content regions’ dimensions I don’t know. Not the most elegant of solutions but it works!

Yes, we also get the odd flickering of 'old videos' – no real way we've found to fix this, however loading a 'blank' .png file in between videos may help. I think it may be something to do with the player not unloading content when it's finished playing (the timeline/region simply gets overwritten with new timeline content when required). It would be good to get some feedback from MS on both of these issues however.

Hope this is of some help to you in the mean time.

Mediaboy

ANOOP

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 742
  • Karma: +23/-0
    • View Profile
Re: Problemas con el Android Player
« Reply #2 on: August 12, 2013, 11:16:43 AM »
You could uncheck the auto rewind function and see if the old video plays back.

ireirenene

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Problemas con el Android Player
« Reply #3 on: August 13, 2013, 02:11:19 AM »
mediaboy and Annop, thank you very much for your help!

Has been solved flickering in transitions and the scale is correct. I put a white image of one second between a resource and another and now the transition is more clean.
I also unchecked the automatic rewind option.

I still have problems with some options (frame rate, video uploading, playback speed, etc..), so I'll be around here. But first try to resolve it. I hope not to be too heavy. =)

ireirenene

ireirenene

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Problemas con el Android Player
« Reply #4 on: August 14, 2013, 02:35:52 AM »
Hi!

I have several problems with the Android Player.

1. The Digital Signage App closes occasionally for no apparent reason. There any error report or error log?

2. Also, after you close the application, I have to open it manually. Is there any way to do this remotely? SignageController has not?

3. Cropping component HTML Web Sites is great but fails.
Players I have Windows and Android Player on Windows worked perfectly but not Android. The scene of the component is larger, screen division hides the date and does not meet the parameters x, y, w, and h. (Attached photo, Android left and right Windows Player. Component is blank space at the bottom left, under the date).

4. The screen is black. Only present date, Cropping component HTML Web Sites and Component News RSS. This occurred after the application is closed and if I change my campaign, if I restart the Player or reinstall the app is the same.

5. The first video from the timeline remains small sometimes. Is displayed at the top left and smaller. Especially the first time you play after updating changes.
I inserted a second target before the initial video and starts a moment later. Possible solutions were given to me by forum users. And possibly I happen less often, but not 100% solved.

I hope someone can help me solve some or all of these problems. Thank you very much!

ireirenene


ANOOP

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 742
  • Karma: +23/-0
    • View Profile
Re: Problemas con el Android Player
« Reply #5 on: August 14, 2013, 08:27:29 AM »
Closing is an issue with the 3rd party sticks, it gets freezed.... Mediasignage has a secret recipe of android for their players , even with signage controller the 3rd party sticks dont work properly :)
In case there is a 3rd party flash file on the website then it wont get displayed on Android player please check the website.
Never have videos in the start of the timeline

 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines