December 06, 2019, 07:28:00 PM
Welcome, Guest. Please login or register
News: Join us for a FREE Webinar this Thursday at http://webinar.digitalsignage.com

MediaSignage support forum



Author Topic: Trying to run signageplayer in Ubuntu 12.10  (Read 1909 times)

blathier1979

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Trying to run signageplayer in Ubuntu 12.10
« on: January 31, 2013, 03:06:56 AM »
I know the linux version is not supported anymore. In any case, I was running signageplayer on Ubuntu 11.04, but updated it to 12.10 recently. The player itself seems to run just fine, and there are no problems with it.

But the problem is that my screen keeps blanking every 5-10 minutes. I have turned off the settings for this in Brightness and Lock, but to no avail. I've also tried to run the following command

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

but still no go. Is there a way to prevent the screen going blank in Ubuntu 12.10?

In windows, you can actually make a batch file, then convert it to an executable file, and then change the extension from .exe to .scr and have the batch file run as the screensaver. You can set the batch file to do whatever you like, such as for example not do anything at all.

Is this possible in Ubuntu/Linux)? Because then I could run a batch file as the screen saver, and instead of it going blank, it would do nothing at all, which would solve the problem.

felixb101

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Trying to run signageplayer in Ubuntu 12.10
« Reply #1 on: March 11, 2013, 10:53:43 AM »
There are many place that screen blanking can occur in Linux in general, here are a few ways to disable it:
In the X configuration file (for some people it is Xorg.conf), use these:
BLANK_DPMS = off
and/or
BLANK_TIME = 0
or other DPMS (which can be disabled as well, completely useless for signage)

Other places to look for, which work great in Debian:
autostart.sh, the startup script that starts X, where you want these lines:
xset -dpms &
xset s noblank &
xset s off &

Hope it helps


 

Carbonate design by Bloc
variant: carbon
SMF 2.0.12 | SMF © 2016, Simple Machines